
Remote Multi-User Editing 
 
This guide will cover the necessary setup steps and best practices for using Multi-User 
Editing in Unreal Engine for remote collaboration. This requires Unreal Engine 4.25 or later. 
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1. Project setup with source control
Multi-User Editing is intended to complement traditional source control in Unreal Engine. For this reason, you will need to 
properly sync your project to the source control system of your choosing; Unreal Engine supports Perforce, Git, Plastic SCM, 
and Subversion. For tips on using the various source control options, view the Source control in Unreal Engine webinar. 
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https://www.youtube.com/watch?v=faYmvw_Pd-A&feature=youtu.be


In our example, we will be using Perforce. Links to documentation for each provider can be found in the additional 
resources section at the end of this guide.

• After installing and opening Unreal Engine, create a new project or select an existing project to launch. Ensure that your 
source control workspace points to the directory where the project is created.

• Once the project opens, select Plugins under the Edit menu.
• Select Built-In, search for Multi-User, and ensure that Multi-User Editing is enabled.
• If the plugin was not already enabled, you will get a message asking you to restart Unreal Engine.
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• In your source control provider, add and submit your project’s .uproject file and Content and Config directories. Do not 
submit Intermediate and Saved. 

• Once a project is in source control, all users who wish to join the Multi-User Session must be on the same changelist. 
This will generally mean being synced to the most recent version.

• Once the project is synced, no local changes should be made before joining the Multi-User Session.
• When syncing your project, close Unreal Engine to avoid issues.
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2. Configuring network and UDP messaging 
settings for VPN use
Before creating or joining a Multi-User Session, all users connecting over VPN will need to configure their UDP messaging 
settings in Unreal Engine.

• If you are using a VPN, ensure that your connection is open and you have been assigned an IP address. From Windows, 
open Command Prompt and type ipconfig. Take note of the IPV4 address associated with the network your Session 
will be on (this will be your VPN if you are using one).

• Re-open your project, but do not modify any content or open any maps.

Hosting a Server

• If you will be hosting a Server, go to Edit > Project Settings > Plugins > Multi-User Editing, expand the Client 
Settings section and select a Server Port for your Multi-User Server such as 7000. Do not use port 6666 or ports 
used by other services on your network.
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Joining a Server

• For those joining a Server, scroll down to Edit > Project Settings > Plugins > UDP Messaging. There are two settings 
that need to be filled in here:

• Unicast Endpoint: should be set to 0.0.0.0:0
• Static Endpoint: There should be a static endpoint set to the IP address of the machine that will be hosting the Multi-

User Server, followed by the port set by the host in the previous step. For example: 123.456.7.8:7000

NOTE: If any of these settings change on the Multi-User host machine, the Server will need to be restarted for the changes 
to take effect.
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3. Hosting a Multi-User Server
Once the project is synced with source control and your UDP messaging settings have been configured, you are ready to 
start a Multi-User Server and Session.

• Open your project and navigate to Window > Developer Tools > Multi-User Browser. This will open the Multi-User 
Browser window.

• Once the Multi-User Browser is open, you will see an option to Launch a Server. Select this option only if you are the 
intended Server host. 

• The Server will launch as a standalone application; 
once it is initialized, you will see the option to add a 
new Session. You can create additional Sessions from 
the Create Session button in the upper-left corner. 
Once you have created the Session, give it a name and 
press Enter to launch it. You will be entered into the 
Session automatically
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Launching the standalone Multi-User Server from the command line

You can also launch this Server from the command line on any computer that has Unreal Engine installed.

If you run the Server from the command line, you don’t need to have your project on that computer. The Server only 
records transactions and modified assets; it has no dependency on having the entire project content available. Only the 
computers that join a Session need to have copies of the project content.

This is a good solution for having a dedicated machine with a Multi-User Server always on, so that people can create Multi-
User Sessions at any time. It is also good for hosting a Multi-User Server on the cloud or to take advantage of a location 
(office) with very high internet bandwidth. There is no need to have Unreal Engine running when using the  standalone 
Multi-User Server. 

• You’ll find the Multi-User Server executable in your Unreal Engine installation folder at Engine\Binaries\\
UnrealMultiUserServer.exe. For example: C:\Program Files\Epic Games\UE_4.25\Engine\Binaries\Win64\
UnrealMultiUserServer.exe.

• When you launch it, you can provide optional parameters on the command line to control its behavior. To configure UDP 
messaging settings, you would use the following parameter.

• -UDPMESSAGING_TRANSPORT_UNICAST=[ip]:[DesiredPort] For example: >UnrealMultiUserServer.exe 
-UDPMESSAGING_TRANSPORT_UNICAST=123.456.7.8:7000 
 

 

• For a complete list of optional parameters and other information relating to using the standalone Multi-User Server, 
view the full reference documentation.
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https://cdn2.unrealengine.com/unreal-engine-multi-user-cloud-setup-360515954.pdf
https://docs.unrealengine.com/en-US/Engine/Editor/MultiUser/Reference/index.html


4. Joining a Multi-User Session
Once a Multi-User Server and Session have been launched on your network, joining is very simple.

• Open your project and navigate to Window > Developer Tools > Multi-User Browser. This will open the Multi-User 
Browser window.

• If a Multi-User Server and Session have been launched, and you have correctly configured your UDP messaging 
settings, you will automatically see the available Sessions on your network. Double-click to join.

5. Multi-User Editing features
Avatars 
 
Each user in a Multi-User Session is represented by an avatar visible to other users. The color and name of this avatar 
can be customized in Project Settings > Plugins > Multi-User Editing.
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Transactions

Multi-User Editing functions by sending changes across the network to be applied on top of a common starting state. 
These changes are called “Transactions”, and properties which are sent are said to be “transacted”. The majority 
of properties on the majority of objects are transacted by default, but if you would like to add or exclude a class for 
transaction, you can do so under Project Settings > Plugins > Multi-User Transactions.

For custom logic executed in Blueprints that you would like to expose, add the following Blueprint nodes:

• Begin Transaction, End Transaction, and Cancel Transaction—All logic executed between these nodes will be 
transacted unless execution reaches a Cancel Transaction node.

• Transact Object—Transact a specific object’s change.
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Multi-User Browser

The Multi-User Browser shows all connected users on a given Session, enabling you to jump to their position or toggle their 
avatar visibility. This window also provides a log of all transacted changes during the Session’s life.

Simultaneous playback in Sequencer

Multi-User Editing is also capable of controlling the Sequencers of all connected clients to facilitate simultaneous playback. 
In order to enable this control, all users must enable several options in their Sequencer. These are, from left to right:

• Toggle Multi-User Playback Sync—This setting will enable all Sequencers with the same level sequence open to have 
their playhead position synced.

• Toggle Multi-User Unrelated Timeline Sync—This setting will enable all Sequencers to sync playhead position 
regardless of which level sequence they have open. This should be disabled if users are working on different 
sequences and do not want playback synced.

• Toggle Multi-User Remote Open—Clients with this setting toggled will have their Sequencer automatically load level 
sequences opened by other users.
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6. Ending a Session
All Multi-User changes are stored on the server and not 
to disk in any one user’s Unreal Engine instance. As a 
result, leaving a Session will restore a user’s project state 
to what it was before joining the Multi-User Session. 
In order for changes made in a Session to be made 
permanent, a user will need to save and persist those 
changes. While any user can perform these steps, it is 
highly recommended that the host be the one to save 
and persist the changes. Ideally, this process should be 
done at least twice a day, and before completing work for 
the day. 

NOTE: Do not run the Session for days or weeks without 
persisting. If the host machine were to become  
permanently non-operational, all work on the server  
would be lost.

• When ready to save and persist, the host should 
navigate to the Source Control button in the toolbar  
and select Persist Session Changes.

• This will bring up an options window listing all 
modified files in the Session. Selecting Submit 
to Source Control will prompt for a changelist 
description and enable you to submit the changes 
directly to source control. Leaving this unchecked 
and continuing will save files to disk, but not to 
source control.

• Once changes have been persisted, you can exit the 
Multi-User Session by clicking the Leave the Current 
Session button in the upper-right corner.
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• You can now close the current Session by right-
clicking on the Session and selecting Delete. 
Alternatively, you can choose to Archive, which  
will store the Session as a snapshot but leave the  
existing Session active. 
 

• Archived Sessions can be restored at a later date 
using the Restore button, enabling users to join the 
Session with the change history from that archive. 

• Once you have finished, you can close the Server 
by hitting the Close Server button or closing the 
Multi-User Server standalone application. All open 
and archived Sessions will still be available when the 
Server is restarted on the same host machine and 
from the same Unreal Engine installation.

14

Remote Multi-User Editing



7. Note on performance capture
Recording performance capture creates files that may be too large for transaction via Multi-User through an internet 
connection, especially when recording raw Live-Link curves. This can be mitigated by recording actors instead of Live-
Link and/or selecting reduced keys on the Take Recorder source’s settings to remove keys considered duplicates within 
a threshold. 

Even with these settings, you will need a server and clients with very high upload and download bandwidths to avoid client/
server hiccups. Updates to improve recording efficiency in Multi-User Editing are currently in development.

15

Remote Multi-User Editing



8. Common errors
A Server is active on my network but Unreal Engine doesn’t see it to join.

• Ensure that both you and the host have completed the UDP messaging setup in section 2.
• Make sure you are using the correct IP and port of the Multi-User Server machine. 

“Failed to join server: The workspace has in memory changes.”

• In order to maintain the same state across all users, Multi-User Editing requires that all users have the same 
starting state. You are receiving this error message because you have modified a file that has yet to be saved before 
attempting to join. Exit Unreal Engine and discard changes, then relaunch to join.

“Failed to join server: The workspace has local changes.”

• In order to maintain the same state across all users, Multi-User Editing requires that all users have the same starting 
state. You are receiving this error message because you have changes to the project in source control that have yet 
to be committed. In order to join, you must revert these changes or submit them and have the other users sync to the 
new changelist.

“LogUdpMessaging: Error: StartTransport failed to create unicast socket on [IP:Port]”

• This error message indicates the Server wasn’t able to start because the IP/port defined was either already in use by 
another application or is invalid. Check your server IP/port and restart the Multi-User Server.

“FUdpSocketBuilder: Failed to create and initialize socket UdpMessageMulticastSocket”

• This error message indicates an incorrect UDP Messaging Multicast endpoint. This IP should not be changed from the 
default unless you have configured advanced settings on your network. Consult the person in charge of your network if 
you believe this address should be different from the default.

You are hosting the Multi-User Server on your local machine, but you don’t see it in your Multi-User Browser. 

• Under Project Settings > Plugins > UDP Messaging, make sure you have the correct Static Endpoints for your 
machine’s IP address and the Multi-User Server port. See section 2.
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Additional resources
Additional Multi-User Editing documentation

Multi-User cloud setup documentation

Unreal Engine source control documentation

Perforce documentation

SVN documentation

Git documentation
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https://docs.unrealengine.com/en-US/Engine/Editor/MultiUser/index.html
https://cdn2.unrealengine.com/unreal-engine-multi-user-cloud-setup-360515954.pdf
https://docs.unrealengine.com/en-US/Engine/UI/SourceControl/index.html
https://www.perforce.com/support/self-service-resources/documentation
https://subversion.apache.org/docs/
https://git-scm.com/doc

